Issue


You are asked to update settings linked to the office 365 account whilst in the OBM and you receive an error similar to below on your backups:


Failed to login to Office 365, reason = com.ahsay.afc.cloud.d: com.ahsay.afc.cloud.office365.E: [Graph

AuthHelper.getOAuthTokenByRefreshTokenAndAppCredentials]Failed to login to Office 365, reason = AADSTS50173: The provided grant has

expired due to it being revoked, a fresh auth token is needed. The user might have changed or reset their password. The grant was issu

ed on '2021-05-25T08:56:56.7343677Z' and the TokensValidFrom date (before which tokens are not valid) for this user is '2021-09-14T14:1

9:52.0000000Z'.rnTrace ID: 20ecb750-e863-49b8-b8ff-dc8e384dad00rnCorrelation ID: fdc64290-6572-48ec-98f0-29e2cc43c2f3rnTimestamp: 2021-

10-12 04:00:19Zn


Cause


This can be caused by the O365 account password being changed and not being updated within the backup set.


Resolution


To resolve please follow the below steps.


1) Login to web portal at portal.vitanium.com/backup


You will need to use the customer's OBM account details:


2) Select the User Tab



2) Go to the backup sets tab 


3) Click on the desired Office 365 backup


4) On the general tab at the bottom click on change settings.  



5) Using Modern Authentication, leave the Username and Account password blank as below and click The arrow in the bottom right. 



5) Click I understand when the sharepoint limitation comes up 


6) Select Authorize when this message pops up:




7)Sign in as the 365 admin account


8) Copy the code provided in the auth page:


        

9) Paste it into the Box in the OBM configuration page and wait for authentication to complete: