Issue:


Office 365 cloud to cloud job  is receiving any of the below errors:


    • com.ahsay.afc.cloud.d: GraphService has not logged in yet


    •  Skip backing up E-mail Account "", Reason = "[Path: Office 365/Users/, Fault

       Mailbox does not exist / user has no Exchange Online license / logged in user does not have                   

       ApplicationImpersonation permission


    • java.lang.Exception: Failed to resolve backup source shortcut paths. Error=[ExchangeOnlineManager.

       CloudCache.listDirectFromCloud]Failed to list sFolderID=null; sPath=Office 365/Users com.ahsay.afc.

       Cloud.office365.exchange.m$4.a(Unknown Source) com.ahsay.afc.cloud.office

 

 •   Office 365/Public Folders" does not exist or current user does not have permission to access the path

Cause:


This will occur when the office 365 account used to run the backup has insufficient permissions and roles assigned.


Resolution:


To resolve please ensure the account has is assigned to the following security groups/Roles in office 365:


    • Discovery Management 

    • Public Folder Management

    • Application Impersonation & Mail Search

    • Legal Hold

    • Mailbox Import Export

    • Mailbox Search

    • Public Folders

    • SharePoint Global Admin